Run tests under python 3.10 (#3035)

* fix SC2086 on mkdir $SEARX_SETTINGS_PATH
* run tests under python 3.10
* Update requirements.txt for now to downgrade transifex

Co-authored-by: Noémi Ványi <sitbackandwait@gmail.com>
pull/3072/head
Maciej "RooTer" Urbański 11 months ago committed by GitHub
parent f0c77a91d1
commit acefa65ac5
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 2
      .github/workflows/data-update.yml
  2. 4
      .github/workflows/integration.yml
  3. 3
      requirements-dev.txt
  4. 2
      utils/searx.sh

@ -29,7 +29,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
python-version: '3.9'
python-version: '3.10'
architecture: 'x64'
- name: Install Python dependencies

@ -13,7 +13,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-20.04]
python-version: [3.7, 3.8, 3.9]
python-version: [3.7, 3.8, 3.9, "3.10"]
steps:
- name: Checkout
uses: actions/checkout@v2
@ -86,7 +86,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
python-version: '3.9'
python-version: '3.10'
architecture: 'x64'
- name: Cache Python dependencies
id: cache-python

@ -4,7 +4,8 @@ cov-core==1.15.0
pycodestyle==2.8.0
pylint==2.12.2
splinter==0.17.0
transifex-client==0.14.3
transifex-client==0.14.3; python_version < '3.10'
transifex-client==0.12.1; python_version == '3.10'
selenium==4.1.0
twine==3.7.1
Pallets-Sphinx-Themes==2.0.2

@ -418,7 +418,7 @@ install_settings() {
err_msg "you have to install searx first"
exit 42
fi
mkdir -p "$(dirname ${SEARX_SETTINGS_PATH})"
mkdir -p "$(dirname "${SEARX_SETTINGS_PATH}")"
if [[ ! -f ${SEARX_SETTINGS_PATH} ]]; then
info_msg "install settings ${SEARX_SETTINGS_TEMPLATE}"

Loading…
Cancel
Save